{"action":"Upgrade poetry to 2.3.3 or later.","affected":[{"fixed":"2.3.3","introduced":"1.4.0"}],"component":"poetry","cve_ids":["CVE-2026-34591"],"ecosystem":"PyPI","epss":0.00468,"exploited":false,"fixed_versions":["2.3.3"],"ghsa_id":"GHSA-2599-h6xx-hpxp","id":"tcs_01M5KERVFBS1D8ZVE17MP1F55W","modified_at":"2026-09-10T03:50:42.075152286Z","published_at":"2026-04-01T22:17:36Z","references":["https://osv.dev/vulnerability/GHSA-2599-h6xx-hpxp","https://github.com/python-poetry/poetry/security/advisories/GHSA-2599-h6xx-hpxp","https://nvd.nist.gov/vuln/detail/CVE-2026-34591","https://github.com/python-poetry/poetry/pull/10792","https://github.com/python-poetry/poetry","https://github.com/python-poetry/poetry/releases/tag/2.3.3","http://github.com/python-poetry/poetry/commit/ed59537ac3709cfbdbf95d957de801c13872991a"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-2599-h6xx-hpxp","url":"https://osv.dev/vulnerability/GHSA-2599-h6xx-hpxp"}],"summary":"Poetry Has Wheel Path Traversal Which Can Lead to Arbitrary File Write"}