{"action":"Upgrade phpseclib/phpseclib to 3.0.34 or later.","affected":[{"fixed":"3.0.34","introduced":"3.0.0"}],"component":"phpseclib/phpseclib","cve_ids":["CVE-2023-49316"],"ecosystem":"Packagist","epss":0.00783,"exploited":false,"fixed_versions":["3.0.34"],"ghsa_id":"GHSA-2f25-pfq3-c7h8","id":"tcs_01M5KERVXAP0153QSX998NV81Z","modified_at":"2026-05-08T23:26:11.544853Z","published_at":"2026-05-08T23:06:50Z","references":["https://osv.dev/vulnerability/GHSA-2f25-pfq3-c7h8","https://github.com/phpseclib/phpseclib/security/advisories/GHSA-2f25-pfq3-c7h8","https://nvd.nist.gov/vuln/detail/CVE-2023-49316","https://github.com/phpseclib/phpseclib/commit/964d78101a70305df33f442f5490f0adb3b7e77f","https://github.com/FriendsOfPHP/security-advisories/blob/master/phpseclib/phpseclib/CVE-2023-49316.yaml","https://github.com/phpseclib/phpseclib","https://github.com/phpseclib/phpseclib/releases/tag/3.0.34"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-2f25-pfq3-c7h8","url":"https://osv.dev/vulnerability/GHSA-2f25-pfq3-c7h8"}],"summary":"Phpseclib needs guardrails on large binaryfield integers"}