{"action":"Upgrade tokio-postgres to 0.7.18 or later.","affected":[{"fixed":"0.7.18","introduced":"0.4.0"}],"component":"tokio-postgres","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["0.7.18"],"ghsa_id":"GHSA-3gjw-f78c-vvpw","id":"tcs_01M5KERXY1GEZD3X6EV5NGWYSC","modified_at":"2026-08-25T02:55:59.557390596Z","published_at":"2026-08-24T19:49:17Z","references":["https://osv.dev/vulnerability/GHSA-3gjw-f78c-vvpw","https://github.com/rust-postgres/rust-postgres/commit/7a00ffa9ad4d951ec0a4564b52f1780fa9d353c1","https://github.com/rust-postgres/rust-postgres","https://github.com/rust-postgres/rust-postgres/releases/tag/tokio-postgres-v0.7.18","https://rustsec.org/advisories/RUSTSEC-2026-0178.html"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-3gjw-f78c-vvpw","url":"https://osv.dev/vulnerability/GHSA-3gjw-f78c-vvpw"}],"summary":"tokio-postgres: Panic on a `DataRow` with fewer fields than columns allows denial of service"}