{"action":"Upgrade github.com/nats-io/nats-server/v2 to 2.1.9 or later.","affected":[{"fixed":"2.1.9","introduced":"0"}],"component":"github.com/nats-io/nats-server/v2","cve_ids":["CVE-2020-26892"],"ecosystem":"Go","epss":0.02328,"exploited":false,"fixed_versions":["2.1.9"],"ghsa_id":"GHSA-2c64-vj8g-vwrq","id":"tcs_01M5KERY5HMJZ3287TQ7NCGY0Q","modified_at":"2026-09-10T03:49:04.052350741Z","published_at":"2021-05-21T16:11:49Z","references":["https://osv.dev/vulnerability/GHSA-2c64-vj8g-vwrq","https://github.com/nats-io/nats-server/security/advisories/GHSA-2c64-vj8g-vwrq","https://github.com/nats-io/jwt/commit/e11ce317263cef69619fc1ca743b195d02aa1d8a","https://advisories.nats.io/CVE/CVE-2020-26892.txt","https://github.com/nats-io/nats-server"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-2c64-vj8g-vwrq","url":"https://osv.dev/vulnerability/GHSA-2c64-vj8g-vwrq"}],"summary":"Incorrect handling of credential expiry by /nats-io/nats-server"}