{"action":"Upgrade moodle/moodle to 3.9.17 or later.","affected":[{"fixed":"3.9.17","introduced":"0"},{"fixed":"3.11.10","introduced":"3.11"},{"fixed":"4.0.4","introduced":"4.0"}],"component":"moodle/moodle","cve_ids":["CVE-2022-40314"],"ecosystem":"Packagist","epss":0.02101,"exploited":false,"fixed_versions":["3.9.17","3.11.10","4.0.4"],"ghsa_id":"GHSA-2hmm-q272-xmhf","id":"tcs_01M5KERZK6NHA6R6Q5DH27ACEZ","modified_at":"2024-04-23T23:58:47.114887Z","published_at":"2022-10-01T00:00:20Z","references":["https://osv.dev/vulnerability/GHSA-2hmm-q272-xmhf","https://nvd.nist.gov/vuln/detail/CVE-2022-40314","https://bugzilla.redhat.com/show_bug.cgi?id=2128147","https://github.com/moodle/moodle","https://moodle.org/mod/forum/discuss.php?d=438393","http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-75405"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-2hmm-q272-xmhf","url":"https://osv.dev/vulnerability/GHSA-2hmm-q272-xmhf"}],"summary":"Moodle remote code execution"}