{"action":"Upgrade moodle/moodle to 3.5.16 or later.","affected":[{"fixed":"3.5.16","introduced":"3.5"},{"fixed":"3.8.7","introduced":"3.8"},{"fixed":"3.9.4","introduced":"3.9"},{"fixed":"3.10.1","introduced":"3.10"}],"component":"moodle/moodle","cve_ids":["CVE-2021-20187"],"ecosystem":"Packagist","epss":0.01591,"exploited":false,"fixed_versions":["3.5.16","3.8.7","3.9.4","3.10.1"],"ghsa_id":"GHSA-2jrm-gww7-wch2","id":"tcs_01M5KES16MJ3QQ8E0NPDGC4PJ1","modified_at":"2024-04-23T23:58:35.180814Z","published_at":"2022-05-24T17:40:31Z","references":["https://osv.dev/vulnerability/GHSA-2jrm-gww7-wch2","https://nvd.nist.gov/vuln/detail/CVE-2021-20187","https://github.com/moodle/moodle","https://moodle.org/mod/forum/discuss.php?d=417171"],"severity":{"label":"high","score":7.2},"sources":[{"source":"osv","source_id":"GHSA-2jrm-gww7-wch2","url":"https://osv.dev/vulnerability/GHSA-2jrm-gww7-wch2"}],"summary":"Moodle Arbitrary PHP code execution by site admins via Shibboleth configuration"}