{"action":"Upgrade pgadmin4 to 8.5 or later.","affected":[{"fixed":"8.5","introduced":"0"}],"component":"pgadmin4","cve_ids":["CVE-2024-3116"],"ecosystem":"PyPI","epss":0.65815,"exploited":false,"fixed_versions":["8.5"],"ghsa_id":"GHSA-27jx-ffw8-xrqv","id":"tcs_01M5KES353J3PMRNGG1HAXJ39D","modified_at":"2026-07-07T17:56:44.492713016Z","published_at":"2024-04-04T15:30:34Z","references":["https://osv.dev/vulnerability/GHSA-27jx-ffw8-xrqv","https://nvd.nist.gov/vuln/detail/CVE-2024-3116","https://github.com/pgadmin-org/pgadmin4/issues/7326","https://github.com/pgadmin-org/pgadmin4/commit/fbbbfe22dd468bcfef1e1f833ec32289a6e56a8b","https://gist.github.com/aelmokhtar/689a8be7e3bd535ec01992d8ec7b2b98","https://github.com/pgadmin-org/pgadmin4","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GIF5T34JTTYRGIN5YPT366BDFG6452A2","https://www.vicarius.io/vsociety/posts/remote-code-execution-vulnerability-in-pgadmin-cve-2024-3116"],"severity":{"label":"high","score":7.4},"sources":[{"source":"osv","source_id":"GHSA-27jx-ffw8-xrqv","url":"https://osv.dev/vulnerability/GHSA-27jx-ffw8-xrqv"}],"summary":"pgAdmin Remote Code Execution (RCE) vulnerability"}