{"action":"Upgrade librenms/librenms to 21.3.0 or later.","affected":[{"fixed":"21.3.0","introduced":"0"}],"component":"librenms/librenms","cve_ids":["CVE-2021-31274"],"ecosystem":"Packagist","epss":0.00778,"exploited":false,"fixed_versions":["21.3.0"],"ghsa_id":"GHSA-2r2w-jrh2-p4gr","id":"tcs_01M5KES74BQ942GTK0DVQJ72J4","modified_at":"2024-02-16T08:06:25.660331Z","published_at":"2021-09-09T17:08:55Z","references":["https://osv.dev/vulnerability/GHSA-2r2w-jrh2-p4gr","https://nvd.nist.gov/vuln/detail/CVE-2021-31274","https://github.com/librenms/librenms/pull/12739","https://community.librenms.org/t/vulnerability-report-cross-site-scripting-xss-in-the-api-access-page/15431","https://github.com/librenms/librenms"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-2r2w-jrh2-p4gr","url":"https://osv.dev/vulnerability/GHSA-2r2w-jrh2-p4gr"}],"summary":"Cross-site Scripting in LibreNMS"}