{"action":"Upgrade apache-superset to 3.1.2 or later.","affected":[{"fixed":"3.1.2","introduced":"0"}],"component":"apache-superset","cve_ids":["CVE-2024-28148"],"ecosystem":"PyPI","epss":0.00705,"exploited":false,"fixed_versions":["3.1.2"],"ghsa_id":"GHSA-299q-3p96-5898","id":"tcs_01M5KES8YVGHJT8BSQPQV7AJ9F","modified_at":"2026-07-07T17:56:52.144667272Z","published_at":"2024-05-07T15:30:36Z","references":["https://osv.dev/vulnerability/GHSA-299q-3p96-5898","https://nvd.nist.gov/vuln/detail/CVE-2024-28148","https://github.com/apache/superset","https://lists.apache.org/thread/n27wlbd05oc6bgjh28d5pxzsrrph8dgo"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-299q-3p96-5898","url":"https://osv.dev/vulnerability/GHSA-299q-3p96-5898"}],"summary":"Apache Superset Incorrect Authorization vulnerability"}