{"action":"Upgrade moodle/moodle to 1.9.17 or later.","affected":[{"fixed":"2.2.2","introduced":"2.2"},{"fixed":"2.1.5","introduced":"2.1"},{"fixed":"2.0.8","introduced":"2.0"},{"fixed":"1.9.17","introduced":"0"}],"component":"moodle/moodle","cve_ids":["CVE-2012-1157"],"ecosystem":"Packagist","epss":0.01216,"exploited":false,"fixed_versions":["2.2.2","2.1.5","2.0.8","1.9.17"],"ghsa_id":"GHSA-2x36-7xfm-pgm7","id":"tcs_01M5KESBZ3WN8ASZWPXS1GY1H6","modified_at":"2023-12-29T21:11:34.652313Z","published_at":"2022-04-23T00:40:10Z","references":["https://osv.dev/vulnerability/GHSA-2x36-7xfm-pgm7","https://nvd.nist.gov/vuln/detail/CVE-2012-1157","https://github.com/moodle/moodle/commit/246c2cb8e5af71a7d7c605b8fc9f9563e0fb3bc4","https://access.redhat.com/security/cve/cve-2012-1157","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-1157","https://github.com/moodle/moodle","https://moodle.org/mod/forum/discuss.php?d=198624","https://security-tracker.debian.org/tracker/CVE-2012-1157","http://lists.fedoraproject.org/pipermail/package-announce/2012-April/077635.html","http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078209.html","http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078210.html","http://lists.fedoraproject.org/pipermail/package-announce/2012-May/080712.html","http://lists.fedoraproject.org/pipermail/package-announce/2012-May/081047.html"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-2x36-7xfm-pgm7","url":"https://osv.dev/vulnerability/GHSA-2x36-7xfm-pgm7"}],"summary":"Moodle default permissions too permissive"}