{"action":"Upgrade firebase/php-jwt to 7.0.0 or later.","affected":[{"fixed":"7.0.0","introduced":"0"}],"component":"firebase/php-jwt","cve_ids":["CVE-2025-45769"],"ecosystem":"Packagist","epss":0.00148,"exploited":false,"fixed_versions":["7.0.0"],"ghsa_id":"GHSA-2x45-7fc3-mxwq","id":"tcs_01M5KESC5ER85BJXDB8HWXK03H","modified_at":"2026-09-10T03:50:25.716459904Z","published_at":"2025-07-31T21:31:53Z","references":["https://osv.dev/vulnerability/GHSA-2x45-7fc3-mxwq","https://nvd.nist.gov/vuln/detail/CVE-2025-45769","https://github.com/firebase/php-jwt/issues/611","https://github.com/firebase/php-jwt/issues/618","https://github.com/firebase/php-jwt/issues/620","https://github.com/firebase/php-jwt/pull/613","https://github.com/github/advisory-database/pull/6954","https://github.com/firebase/php-jwt/commit/6b80341bf57838ea2d011487917337901cd71576","https://gist.github.com/ZupeiNie/83756316c4c24fe97a50176a92608db3","https://github.com/advisories/GHSA-2x45-7fc3-mxwq","https://github.com/firebase","https://github.com/firebase/php-jwt","https://github.com/firebase/php-jwt/releases/tag/v7.0.0"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-2x45-7fc3-mxwq","url":"https://osv.dev/vulnerability/GHSA-2x45-7fc3-mxwq"}],"summary":"php-jwt contains weak encryption"}