{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29523"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-2cpx-427x-q2c6","id":"tcs_01M5KESEDG0EHC04PFDFXE32YS","modified_at":"2026-07-08T06:29:52.740836584Z","published_at":"2021-05-21T14:21:43Z","references":["https://osv.dev/vulnerability/GHSA-2cpx-427x-q2c6","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-2cpx-427x-q2c6","https://nvd.nist.gov/vuln/detail/CVE-2021-29523","https://github.com/tensorflow/tensorflow/commit/69c68ecbb24dff3fa0e46da0d16c821a2dd22d7c","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-451.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-649.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-160.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-2cpx-427x-q2c6#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-2cpx-427x-q2c6"}],"summary":"CHECK-fail in AddManySparseToTensorsMap"}