{"action":"Upgrade python-gnupg to 0.4.4 or later.","affected":[{"fixed":"0.4.4","introduced":"0"}],"component":"python-gnupg","cve_ids":["CVE-2019-6690"],"ecosystem":"PyPI","epss":0.08617,"exploited":false,"fixed_versions":["0.4.4"],"ghsa_id":"GHSA-2fch-jvg5-crf6","id":"tcs_01M5KESFX7TTD4R31DQKWG6MSG","modified_at":"2024-02-22T05:23:39.176453Z","published_at":"2019-03-25T16:17:53Z","references":["https://osv.dev/vulnerability/GHSA-2fch-jvg5-crf6","https://nvd.nist.gov/vuln/detail/CVE-2019-6690","https://blog.hackeriet.no/cve-2019-6690-python-gnupg-vulnerability","https://github.com/advisories/GHSA-2fch-jvg5-crf6","https://lists.debian.org/debian-lts-announce/2019/02/msg00021.html","https://lists.debian.org/debian-lts-announce/2021/12/msg00027.html","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3WMV6XNPPL3VB3RQRFFOBCJ3AGWC4K47","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/W6KYZMN2PWXY4ENZVJUVTGFBVYEVY7II","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/X4VFRUG56542LTYK4444TPJBGR57MT25","https://pypi.org/project/python-gnupg/#history","https://seclists.org/bugtraq/2019/Jan/41","https://usn.ubuntu.com/3964-1","https://web.archive.org/web/20200227091727/http://www.securityfocus.com/bid/106756","http://lists.opensuse.org/opensuse-security-announce/2019-02/msg00008.html","http://lists.opensuse.org/opensuse-security-announce/2019-02/msg00058.html","http://packetstormsecurity.com/files/151341/Python-GnuPG-0.4.3-Improper-Input-Validation.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-2fch-jvg5-crf6","url":"https://osv.dev/vulnerability/GHSA-2fch-jvg5-crf6"}],"summary":"Improper Input Validation python-gnupg"}