{"action":"Upgrade werkzeug to 3.0.3 or later.","affected":[{"fixed":"3.0.3","introduced":"0"}],"component":"werkzeug","cve_ids":["CVE-2024-34069"],"ecosystem":"PyPI","epss":0.03397,"exploited":false,"fixed_versions":["3.0.3"],"ghsa_id":"GHSA-2g68-c3qc-8985","id":"tcs_01M5KESHSTH4DET3GEKQBZYKYC","modified_at":"2026-09-10T03:50:13.189126850Z","published_at":"2024-05-06T14:21:27Z","references":["https://osv.dev/vulnerability/GHSA-2g68-c3qc-8985","https://github.com/pallets/werkzeug/security/advisories/GHSA-2g68-c3qc-8985","https://nvd.nist.gov/vuln/detail/CVE-2024-34069","https://github.com/pallets/werkzeug/commit/3386395b24c7371db11a5b8eaac0c91da5362692","https://github.com/pallets/werkzeug","https://lists.debian.org/debian-lts-announce/2025/02/msg00026.html","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/H4SH32AM3CTPMAAEOIDAN7VU565LO4IR","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HFERFN7PINV4MOGMGA3DPIXJPDCYOEJZ","https://security.netapp.com/advisory/ntap-20240614-0004"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-2g68-c3qc-8985","url":"https://osv.dev/vulnerability/GHSA-2g68-c3qc-8985"}],"summary":"Werkzeug debugger vulnerable to remote execution when interacting with attacker controlled domain"}