{"action":"Upgrade github.com/rancher/rancher to 2.9.4 or later.","affected":[{"fixed":"2.9.4","introduced":"2.9.0"}],"component":"github.com/rancher/rancher","cve_ids":["CVE-2024-52281"],"ecosystem":"Go","epss":0.00555,"exploited":false,"fixed_versions":["2.9.4"],"ghsa_id":"GHSA-2v2w-8v8c-wcm9","id":"tcs_01M5KESM7ZNAN3Z3B8NADG2SXY","modified_at":"2026-09-10T03:50:21.767119104Z","published_at":"2025-01-14T22:03:33Z","references":["https://osv.dev/vulnerability/GHSA-2v2w-8v8c-wcm9","https://github.com/rancher/rancher/security/advisories/GHSA-2v2w-8v8c-wcm9","https://nvd.nist.gov/vuln/detail/CVE-2024-52281","https://bugzilla.suse.com/show_bug.cgi?id=CVE-2024-52281","https://github.com/rancher/rancher"],"severity":{"label":"high","score":8.9},"sources":[{"source":"osv","source_id":"GHSA-2v2w-8v8c-wcm9","url":"https://osv.dev/vulnerability/GHSA-2v2w-8v8c-wcm9"}],"summary":"Rancher UI has Stored Cross-site Scripting vulnerability"}