{"action":"Upgrade tonic to 0.12.3 or later.","affected":[{"fixed":"0.12.3","introduced":"0.12.2"}],"component":"tonic","cve_ids":["CVE-2024-47609"],"ecosystem":"crates.io","epss":0.00622,"exploited":false,"fixed_versions":["0.12.3"],"ghsa_id":"GHSA-4jwc-w2hc-78qv","id":"tcs_01M5KESNGZ8H6TCA7HJP7AJQQR","modified_at":"2026-09-10T03:50:19.287633700Z","published_at":"2024-10-01T22:27:58Z","references":["https://osv.dev/vulnerability/GHSA-4jwc-w2hc-78qv","https://github.com/hyperium/tonic/security/advisories/GHSA-4jwc-w2hc-78qv","https://nvd.nist.gov/vuln/detail/CVE-2024-47609","https://github.com/hyperium/tonic/issues/1897","https://github.com/hyperium/tonic/commit/a4472a86f3290e60c7c01348b7e6a8164d6e7e48","https://github.com/hyperium/tonic","https://rustsec.org/advisories/RUSTSEC-2024-0376.html"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-4jwc-w2hc-78qv","url":"https://osv.dev/vulnerability/GHSA-4jwc-w2hc-78qv"}],"summary":"Tonic has remotely exploitable denial of service vulnerability"}