{"action":"Upgrade pterodactyl/panel to 1.11.6 or later.","affected":[{"fixed":"1.11.6","introduced":"0"}],"component":"pterodactyl/panel","cve_ids":["CVE-2024-34067"],"ecosystem":"Packagist","epss":0.00457,"exploited":false,"fixed_versions":["1.11.6"],"ghsa_id":"GHSA-384w-wffr-x63q","id":"tcs_01M5KESR5FV6NQ206G7RFB9G65","modified_at":"2026-09-10T03:50:13.077206883Z","published_at":"2024-05-03T20:29:04Z","references":["https://osv.dev/vulnerability/GHSA-384w-wffr-x63q","https://github.com/pterodactyl/panel/security/advisories/GHSA-384w-wffr-x63q","https://nvd.nist.gov/vuln/detail/CVE-2024-34067","https://github.com/pterodactyl/panel/commit/0dad4c5a488661f9adc27dd311542516d9bfa0f2","https://github.com/pterodactyl/panel/commit/1172d71d31561c4e465dabdf6b838e64de48ad16","https://github.com/pterodactyl/panel/commit/f671046947e4695b5e1c647df79305c1cefdf817","https://github.com/pterodactyl/panel"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-384w-wffr-x63q","url":"https://osv.dev/vulnerability/GHSA-384w-wffr-x63q"}],"summary":"Pterodactyl panel's admin area vulnerable to Cross-site Scripting"}