{"action":"Upgrade magento/community-edition to 2.3.7 or later.","affected":[{"fixed":"2.4.2-p1","introduced":"2.4.0"},{"fixed":"2.3.7","introduced":"0"}],"component":"magento/community-edition","cve_ids":["CVE-2021-28556"],"ecosystem":"Packagist","epss":0.01397,"exploited":false,"fixed_versions":["2.4.2-p1","2.3.7"],"ghsa_id":"GHSA-39ch-rg26-gmq5","id":"tcs_01M5KESV2ZF61YM73R30G98F6V","modified_at":"2025-02-10T21:28:59.014933Z","published_at":"2022-05-24T19:06:25Z","references":["https://osv.dev/vulnerability/GHSA-39ch-rg26-gmq5","https://nvd.nist.gov/vuln/detail/CVE-2021-28556","https://github.com/magento/magento2/commit/1bd5cb8c065e44779526c0b044ce19b884707695","https://github.com/magento/magento2","https://helpx.adobe.com/security/products/magento/apsb21-30.html"],"severity":{"label":"medium","score":6.9},"sources":[{"source":"osv","source_id":"GHSA-39ch-rg26-gmq5","url":"https://osv.dev/vulnerability/GHSA-39ch-rg26-gmq5"}],"summary":"Magento DOM-based Cross-Site Scripting vulnerability on mage-messages cookies"}