{"action":"Upgrade apache-superset to 4.0.2 or later.","affected":[{"fixed":"4.0.2","introduced":"0"}],"component":"apache-superset","cve_ids":["CVE-2024-39887"],"ecosystem":"PyPI","epss":0.04433,"exploited":false,"fixed_versions":["4.0.2"],"ghsa_id":"GHSA-2q6j-vpvr-6pvj","id":"tcs_01M5KET1TZ133SM2KBMM33P5KK","modified_at":"2026-07-07T17:57:26.607065124Z","published_at":"2024-07-16T12:30:37Z","references":["https://osv.dev/vulnerability/GHSA-2q6j-vpvr-6pvj","https://nvd.nist.gov/vuln/detail/CVE-2024-39887","https://github.com/apache/superset/commit/56f0103b5771d477dd106272abbd8021c9ea7506","https://github.com/apache/superset","https://lists.apache.org/thread/j55vm41jg3l0x6w49zrmvbf3k0ts5fqz","http://www.openwall.com/lists/oss-security/2024/07/16/5"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-2q6j-vpvr-6pvj","url":"https://osv.dev/vulnerability/GHSA-2q6j-vpvr-6pvj"}],"summary":"Apache Superset vulnerable to improper SQL authorization"}