{"action":"Upgrade vyper to 0.4.0 or later.","affected":[{"fixed":"0.4.0","introduced":"0.3.0"}],"component":"vyper","cve_ids":["CVE-2024-22419"],"ecosystem":"PyPI","epss":0.0077,"exploited":false,"fixed_versions":["0.4.0"],"ghsa_id":"GHSA-2q8v-3gqq-4f8p","id":"tcs_01M5KET26X77AQZ3E64SZKAR6F","modified_at":"2026-09-10T03:50:04.648916948Z","published_at":"2024-01-19T16:19:51Z","references":["https://osv.dev/vulnerability/GHSA-2q8v-3gqq-4f8p","https://github.com/vyperlang/vyper/security/advisories/GHSA-2q8v-3gqq-4f8p","https://nvd.nist.gov/vuln/detail/CVE-2024-22419","https://github.com/vyperlang/vyper/issues/3737","https://github.com/vyperlang/vyper/commit/55e18f6d128b2da8986adbbcccf1cd59a4b9ad6f","https://github.com/pypa/advisory-database/tree/main/vulns/vyper/PYSEC-2024-103.yaml","https://github.com/vyperlang/vyper"],"severity":{"label":"high","score":7.3},"sources":[{"source":"osv","source_id":"GHSA-2q8v-3gqq-4f8p","url":"https://osv.dev/vulnerability/GHSA-2q8v-3gqq-4f8p"}],"summary":"concat built-in can corrupt memory in vyper"}