{"action":"Upgrade code-server to 3.12.0 or later.","affected":[{"fixed":"3.12.0","introduced":"0"}],"component":"code-server","cve_ids":["CVE-2021-42648"],"ecosystem":"npm","epss":0.00869,"exploited":false,"fixed_versions":["3.12.0"],"ghsa_id":"GHSA-2gp3-6c9p-jp7w","id":"tcs_01M5KET3D3V2XFXEF8FR7BRZZS","modified_at":"2026-09-10T03:49:07.202549818Z","published_at":"2022-05-12T00:00:40Z","references":["https://osv.dev/vulnerability/GHSA-2gp3-6c9p-jp7w","https://nvd.nist.gov/vuln/detail/CVE-2021-42648","https://github.com/cdr/code-server/issues/4355","https://github.com/coder/code-server/pull/4430","https://github.com/coder/code-server"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-2gp3-6c9p-jp7w","url":"https://osv.dev/vulnerability/GHSA-2gp3-6c9p-jp7w"}],"summary":"Cross site scripting in code-server"}