{"action":"Upgrade deepseek-tui to 0.8.41 or later.","affected":[{"fixed":"0.8.41","introduced":"0.8.8"}],"component":"deepseek-tui","cve_ids":["CVE-2026-75859"],"ecosystem":"npm","epss":0.0053,"exploited":false,"fixed_versions":["0.8.41"],"ghsa_id":"GHSA-62f5-cp2p-vq95","id":"tcs_01M5KETC1BK2PPNTB45K51GZFV","modified_at":"2026-09-04T19:00:04.299243037Z","published_at":"2026-09-04T18:00:37Z","references":["https://osv.dev/vulnerability/GHSA-62f5-cp2p-vq95","https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-62f5-cp2p-vq95","https://nvd.nist.gov/vuln/detail/CVE-2026-75859","https://github.com/Hmbown/CodeWhale/commit/43563356b98c6b993085554da82e77370160a31c","https://github.com/Hmbown/CodeWhale","https://www.vulncheck.com/advisories/codewhale-before-arbitrary-file-read-via-instructions"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-62f5-cp2p-vq95#npm/deepseek-tui","url":"https://osv.dev/vulnerability/GHSA-62f5-cp2p-vq95"}],"summary":"CodeWhale: Project config `instructions` override enables arbitrary file read into AI system prompt via cloned repository"}