{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29612"],"ecosystem":"PyPI","epss":0.00287,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-2xgj-xhgf-ggjv","id":"tcs_01M5KETG52W6MHRCVERYR92EEM","modified_at":"2026-07-08T06:28:29.619268682Z","published_at":"2021-05-21T14:28:37Z","references":["https://osv.dev/vulnerability/GHSA-2xgj-xhgf-ggjv","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-2xgj-xhgf-ggjv","https://nvd.nist.gov/vuln/detail/CVE-2021-29612","https://github.com/tensorflow/tensorflow/commit/0ab290774f91a23bebe30a358fde4e53ab4876a0","https://github.com/tensorflow/tensorflow/commit/ba6822bd7b7324ba201a28b2f278c29a98edbef2","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-540.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-738.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-249.yaml"],"severity":{"label":"low","score":3.6},"sources":[{"source":"osv","source_id":"GHSA-2xgj-xhgf-ggjv#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-2xgj-xhgf-ggjv"}],"summary":"Heap buffer overflow in `BandedTriangularSolve`"}