{"action":"Upgrade pyspark to 3.3.2 or later.","affected":[{"fixed":"3.3.2","introduced":"0"}],"component":"pyspark","cve_ids":["CVE-2023-22946"],"ecosystem":"PyPI","epss":0.01109,"exploited":false,"fixed_versions":["3.3.2"],"ghsa_id":"GHSA-329j-jfvr-rhr6","id":"tcs_01M5KETJCPSRSH3BP7NPN639J7","modified_at":"2024-10-15T18:49:31.436249Z","published_at":"2023-04-17T09:30:23Z","references":["https://osv.dev/vulnerability/GHSA-329j-jfvr-rhr6","https://nvd.nist.gov/vuln/detail/CVE-2023-22946","https://github.com/apache/spark/pull/39474","https://github.com/apache/spark/pull/41428","https://github.com/apache/spark/commit/909da96e1471886a01a9e1def93630c4fd40e74a","https://github.com/degant/spark/commit/bfba57724d2520e0fcaa7990f7257c21d11cd75a","https://github.com/apache/spark","https://github.com/pypa/advisory-database/tree/main/vulns/pyspark/PYSEC-2023-44.yaml","https://issues.apache.org/jira/browse/SPARK-41958","https://lists.apache.org/thread/yllfl25xh5tbotjmg93zrq4bzwhqc0gv"],"severity":{"label":"critical","score":9.9},"sources":[{"source":"osv","source_id":"GHSA-329j-jfvr-rhr6","url":"https://osv.dev/vulnerability/GHSA-329j-jfvr-rhr6"}],"summary":"Apache Spark vulnerable to Improper Privilege Management"}