{"action":"Upgrade flask-appbuilder to 4.1.3 or later.","affected":[{"fixed":"4.1.3","introduced":"0"}],"component":"flask-appbuilder","cve_ids":["CVE-2022-31177"],"ecosystem":"PyPI","epss":0.00765,"exploited":false,"fixed_versions":["4.1.3"],"ghsa_id":"GHSA-32ff-4g79-vgfc","id":"tcs_01M5KETJKTWS7V3ZVNBEDZ3N5W","modified_at":"2025-03-07T19:12:54.576183Z","published_at":"2022-07-29T22:28:12Z","references":["https://osv.dev/vulnerability/GHSA-32ff-4g79-vgfc","https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-32ff-4g79-vgfc","https://nvd.nist.gov/vuln/detail/CVE-2022-31177","https://github.com/dpgaspar/Flask-AppBuilder","https://github.com/dpgaspar/Flask-AppBuilder/releases/tag/v4.1.3","https://github.com/pypa/advisory-database/tree/main/vulns/flask-appbuilder/PYSEC-2022-247.yaml"],"severity":{"label":"low","score":2.7},"sources":[{"source":"osv","source_id":"GHSA-32ff-4g79-vgfc","url":"https://osv.dev/vulnerability/GHSA-32ff-4g79-vgfc"}],"summary":"Flask-AppBuilder before v4.1.3 allows inference of sensitive information through query strings"}