{"action":"Upgrade arrayfire to 3.6.0 or later.","affected":[{"fixed":"3.6.0","introduced":"0"}],"component":"arrayfire","cve_ids":["CVE-2018-20998"],"ecosystem":"PyPI","epss":0.01658,"exploited":false,"fixed_versions":["3.6.0"],"ghsa_id":"GHSA-69fv-gw6g-8ccg","id":"tcs_01M5KETM836FSN31BN762PMY6X","modified_at":"2024-09-12T20:52:04.541612Z","published_at":"2021-08-25T20:43:26Z","references":["https://osv.dev/vulnerability/GHSA-69fv-gw6g-8ccg","https://nvd.nist.gov/vuln/detail/CVE-2018-20998","https://github.com/arrayfire/arrayfire-rust/pull/177","https://github.com/arrayfire/arrayfire-rust/commit/a5256f3e5e23b83eaad69699e0b04653aba04fb8","https://github.com/arrayfire/arrayfire-rust","https://github.com/pypa/advisory-database/tree/main/vulns/arrayfire/PYSEC-2019-144.yaml","https://rustsec.org/advisories/RUSTSEC-2018-0011.html"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-69fv-gw6g-8ccg#PyPI/arrayfire","url":"https://osv.dev/vulnerability/GHSA-69fv-gw6g-8ccg"}],"summary":"Potential memory corruption in arrayfire"}