{"action":"Upgrade rosenpass to 0.2.1 or later.","affected":[{"fixed":"0.2.1","introduced":"0"}],"component":"rosenpass","cve_ids":["CVE-2023-53157"],"ecosystem":"crates.io","epss":0.00582,"exploited":false,"fixed_versions":["0.2.1"],"ghsa_id":"GHSA-6ggr-cwv4-g7qg","id":"tcs_01M5KETPEETG7GJZ6CSTW75295","modified_at":"2025-07-28T15:59:15.910294Z","published_at":"2023-12-21T23:15:57Z","references":["https://osv.dev/vulnerability/GHSA-6ggr-cwv4-g7qg","https://nvd.nist.gov/vuln/detail/CVE-2023-53157","https://github.com/rosenpass/rosenpass/commit/93439858d1c44294a7b377f775c4fc897a370bb2","https://github.com/rosenpass/rosenpass","https://rustsec.org/advisories/RUSTSEC-2023-0077.html"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-6ggr-cwv4-g7qg","url":"https://osv.dev/vulnerability/GHSA-6ggr-cwv4-g7qg"}],"summary":"Remotely exploitable denial of service in Rosenpass"}