{"action":"Upgrade moodle/moodle to 4.1.9 or later.","affected":[{"fixed":"4.3.3","introduced":"4.3.0"},{"fixed":"4.2.6","introduced":"4.2.0"},{"fixed":"4.1.9","introduced":"0"}],"component":"moodle/moodle","cve_ids":["CVE-2024-25978"],"ecosystem":"Packagist","epss":0.00944,"exploited":false,"fixed_versions":["4.3.3","4.2.6","4.1.9"],"ghsa_id":"GHSA-487g-3m3v-hjhq","id":"tcs_01M5KETT444QNGRGK25GZZR021","modified_at":"2025-01-23T22:35:21.054007Z","published_at":"2024-02-19T18:31:32Z","references":["https://osv.dev/vulnerability/GHSA-487g-3m3v-hjhq","https://nvd.nist.gov/vuln/detail/CVE-2024-25978","https://github.com/moodle/moodle/commit/9ba14233597480fb78c04d531050c090de4e60a2","https://github.com/moodle/moodle/commit/a73e0ac76d77b67602f91bb211962813d60bc573","https://bugzilla.redhat.com/show_bug.cgi?id=2264074","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KXGBYJ43BUEBUAQZU3DT5I5A3YLF47CB","https://moodle.org/mod/forum/discuss.php?d=455634","http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-74641"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-487g-3m3v-hjhq","url":"https://osv.dev/vulnerability/GHSA-487g-3m3v-hjhq"}],"summary":"Uncontrolled Resource Consumption in moodle"}