{"action":"Upgrade apache-superset to 4.1.0 or later.","affected":[{"fixed":"4.1.0","introduced":"2.0.0"}],"component":"apache-superset","cve_ids":["CVE-2024-53949"],"ecosystem":"PyPI","epss":0.00716,"exploited":false,"fixed_versions":["4.1.0"],"ghsa_id":"GHSA-35fc-9hrj-3585","id":"tcs_01M5KETXS23JG9DJ8TN8EMKPJN","modified_at":"2026-07-07T17:56:20.799591812Z","published_at":"2024-12-09T15:31:37Z","references":["https://osv.dev/vulnerability/GHSA-35fc-9hrj-3585","https://nvd.nist.gov/vuln/detail/CVE-2024-53949","https://github.com/apache/superset/commit/7650c47e72f28559e91524f5d68d50c2060df4c7","https://github.com/apache/superset","https://lists.apache.org/thread/d3scbwmfpzbpm6npnzdw5y4owtqqyq8d","http://www.openwall.com/lists/oss-security/2024/12/09/4"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-35fc-9hrj-3585","url":"https://osv.dev/vulnerability/GHSA-35fc-9hrj-3585"}],"summary":"Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled"}