{"action":"Upgrade moodle/moodle to 4.1.12 or later.","affected":[{"fixed":"4.4.2","introduced":"4.4.0"},{"fixed":"4.3.6","introduced":"4.3.0"},{"fixed":"4.2.9","introduced":"4.2.0"},{"fixed":"4.1.12","introduced":"0"}],"component":"moodle/moodle","cve_ids":["CVE-2024-43435"],"ecosystem":"Packagist","epss":0.00345,"exploited":false,"fixed_versions":["4.4.2","4.3.6","4.2.9","4.1.12"],"ghsa_id":"GHSA-4gq2-x5w4-7hp8","id":"tcs_01M5KETZH5G31E1050VCSGCTVA","modified_at":"2025-05-02T06:59:05.065105Z","published_at":"2024-11-11T15:31:00Z","references":["https://osv.dev/vulnerability/GHSA-4gq2-x5w4-7hp8","https://nvd.nist.gov/vuln/detail/CVE-2024-43435","https://bugzilla.redhat.com/show_bug.cgi?id=2304263","https://github.com/moodle/moodle","https://moodle.org/mod/forum/discuss.php?d=461205","http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-64984"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-4gq2-x5w4-7hp8","url":"https://osv.dev/vulnerability/GHSA-4gq2-x5w4-7hp8"}],"summary":"Moodle has insufficient capability checks"}