{"action":"Upgrade pgp to 0.19.0 or later.","affected":[{"fixed":"0.19.0","introduced":"0.16.0-alpha.0"}],"component":"pgp","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["0.19.0"],"ghsa_id":"GHSA-7587-4wv6-m68m","id":"tcs_01M5KETZR3Q04FT7N3PBQY8725","modified_at":"2026-02-22T23:32:10.037700Z","published_at":"2026-02-13T20:54:19Z","references":["https://osv.dev/vulnerability/GHSA-7587-4wv6-m68m","https://github.com/rpgp/rpgp/security/advisories/GHSA-7587-4wv6-m68m","https://github.com/rpgp/rpgp/pull/698","https://github.com/rpgp/rpgp/commit/38efa49ce18b3821649de9cd8dea88a959b833a5","https://github.com/rpgp/rpgp"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-7587-4wv6-m68m","url":"https://osv.dev/vulnerability/GHSA-7587-4wv6-m68m"}],"summary":"rPGP vulnerable to parser crash on crafted RSA secret key packets through CVE-2026-21895"}