{"action":"Upgrade moodle/moodle to 4.1.12 or later.","affected":[{"fixed":"4.4.2","introduced":"4.4.0"},{"fixed":"4.3.6","introduced":"4.3.0"},{"fixed":"4.2.9","introduced":"4.2.0"},{"fixed":"4.1.12","introduced":"0"}],"component":"moodle/moodle","cve_ids":["CVE-2024-43437"],"ecosystem":"Packagist","epss":0.00333,"exploited":false,"fixed_versions":["4.4.2","4.3.6","4.2.9","4.1.12"],"ghsa_id":"GHSA-4hjf-6pxr-549h","id":"tcs_01M5KEV0ZRKNF9C7MBC915HFQP","modified_at":"2025-04-24T07:57:04.402973Z","published_at":"2024-11-11T15:31:01Z","references":["https://osv.dev/vulnerability/GHSA-4hjf-6pxr-549h","https://nvd.nist.gov/vuln/detail/CVE-2024-43437","https://bugzilla.redhat.com/show_bug.cgi?id=2304266","https://github.com/moodle/moodle","https://moodle.org/mod/forum/discuss.php?d=461207","http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-81394"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-4hjf-6pxr-549h","url":"https://osv.dev/vulnerability/GHSA-4hjf-6pxr-549h"}],"summary":"Moodle Cross-site Scripting vulnerability"}