{"action":"Upgrade ansi_up to 5.0.0 or later.","affected":[{"fixed":"5.0.0","introduced":"0"}],"component":"ansi_up","cve_ids":["CVE-2021-3377"],"ecosystem":"npm","epss":0.08,"exploited":false,"fixed_versions":["5.0.0"],"ghsa_id":"GHSA-2v5f-23xc-v9qr","id":"tcs_01M5KEV3C46EVSK26DVCBYYD3V","modified_at":"2025-11-04T16:33:40Z","published_at":"2021-03-11T22:50:39Z","references":["https://osv.dev/vulnerability/GHSA-2v5f-23xc-v9qr","https://nvd.nist.gov/vuln/detail/CVE-2021-3377","https://github.com/drudru/ansi_up/commit/c8c726ed1db979bae4f257b7fa41775155ba2e27","https://doyensec.com/resources/Doyensec_Advisory_ansi_up4_XSS.pdf","https://security.netapp.com/advisory/ntap-20241108-0002"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-2v5f-23xc-v9qr","url":"https://osv.dev/vulnerability/GHSA-2v5f-23xc-v9qr"}],"summary":"ansi_up cross-site scripting vulnerability"}