{"action":"Upgrade apollo-compiler to 1.27.0 or later.","affected":[{"fixed":"1.27.0","introduced":"0"}],"component":"apollo-compiler","cve_ids":["CVE-2025-31496"],"ecosystem":"crates.io","epss":0.00429,"exploited":false,"fixed_versions":["1.27.0"],"ghsa_id":"GHSA-7mpv-9xg6-5r79","id":"tcs_01M5KEVBBWVZQM0RA4X000HDVB","modified_at":"2025-04-08T17:49:31Z","published_at":"2025-04-07T19:09:14Z","references":["https://osv.dev/vulnerability/GHSA-7mpv-9xg6-5r79","https://github.com/apollographql/apollo-rs/security/advisories/GHSA-7mpv-9xg6-5r79","https://nvd.nist.gov/vuln/detail/CVE-2025-31496","https://github.com/apollographql/apollo-rs/pull/952","https://github.com/apollographql/apollo-rs"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-7mpv-9xg6-5r79","url":"https://osv.dev/vulnerability/GHSA-7mpv-9xg6-5r79"}],"summary":"Apollo Compiler Named Fragment Processing Vulnerability"}