{"action":"Upgrade apollo-router to 1.61.2 or later.","affected":[{"fixed":"1.61.2","introduced":"0"},{"fixed":"2.1.1","introduced":"2.0.0-alpha.0"}],"component":"apollo-router","cve_ids":["CVE-2025-32033"],"ecosystem":"crates.io","epss":0.00596,"exploited":false,"fixed_versions":["1.61.2","2.1.1"],"ghsa_id":"GHSA-84m6-5m72-45fp","id":"tcs_01M5KEVK2EG57108FS44ZQ9D57","modified_at":"2025-04-08T17:50:40Z","published_at":"2025-04-07T18:59:21Z","references":["https://osv.dev/vulnerability/GHSA-84m6-5m72-45fp","https://github.com/apollographql/router/security/advisories/GHSA-84m6-5m72-45fp","https://nvd.nist.gov/vuln/detail/CVE-2025-32033","https://github.com/apollographql/router/commit/ab6675a63174715ea6ff50881fc957831d4e9564","https://github.com/apollographql/router/commit/bba032e183b861348a466d3123c7137a1ae18952","https://github.com/apollographql/router"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-84m6-5m72-45fp","url":"https://osv.dev/vulnerability/GHSA-84m6-5m72-45fp"}],"summary":"Apollo Router Operation Limits Vulnerable to Bypass via Integer Overflow"}