{"action":"Upgrade tensorflow to 2.4.4 or later.","affected":[{"fixed":"2.6.1","introduced":"2.6.0"},{"fixed":"2.5.2","introduced":"2.5.0"},{"fixed":"2.4.4","introduced":"0"}],"component":"tensorflow","cve_ids":["CVE-2021-41216"],"ecosystem":"PyPI","epss":0.00161,"exploited":false,"fixed_versions":["2.6.1","2.5.2","2.4.4"],"ghsa_id":"GHSA-3ff2-r28g-w7h9","id":"tcs_01M5KEVPE7JED928TFB7CBJRJ3","modified_at":"2026-07-08T06:28:09.424674617Z","published_at":"2021-11-10T18:57:19Z","references":["https://osv.dev/vulnerability/GHSA-3ff2-r28g-w7h9","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-3ff2-r28g-w7h9","https://nvd.nist.gov/vuln/detail/CVE-2021-41216","https://github.com/tensorflow/tensorflow/commit/c79ba87153ee343401dbe9d1954d7f79e521eb14","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-625.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-823.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-408.yaml","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/blob/8d72537c6abf5a44103b57b9c2e22c14f5f49698/tensorflow/core/ops/array_ops.cc#L121-L185"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"GHSA-3ff2-r28g-w7h9","url":"https://osv.dev/vulnerability/GHSA-3ff2-r28g-w7h9"}],"summary":"Heap buffer overflow in `Transpose`"}