{"action":"Upgrade beets to 2.10.0 or later.","affected":[{"fixed":"2.10.0","introduced":"0"}],"component":"beets","cve_ids":["CVE-2026-42052"],"ecosystem":"PyPI","epss":0.003,"exploited":false,"fixed_versions":["2.10.0"],"ghsa_id":"GHSA-3gxm-wfjx-m847","id":"tcs_01M5KEVV2TTJGCJ6MACNCRWB26","modified_at":"2026-07-13T16:43:02.903245880Z","published_at":"2026-04-29T18:29:00Z","references":["https://osv.dev/vulnerability/GHSA-3gxm-wfjx-m847","https://github.com/beetbox/beets/security/advisories/GHSA-3gxm-wfjx-m847","https://nvd.nist.gov/vuln/detail/CVE-2026-42052","https://github.com/beetbox/beets","https://github.com/beetbox/beets/releases/tag/v2.10.0","https://lists.debian.org/debian-lts-announce/2026/06/msg00030.html"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-3gxm-wfjx-m847","url":"https://osv.dev/vulnerability/GHSA-3gxm-wfjx-m847"}],"summary":"beets has a Cross-site Scripting vulnerability"}