{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29569"],"ecosystem":"PyPI","epss":0.00198,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-3h8m-483j-7xxm","id":"tcs_01M5KEVW0ZVT12X19WQJ7FJNBJ","modified_at":"2026-07-08T06:28:49.725713431Z","published_at":"2021-05-21T14:25:22Z","references":["https://osv.dev/vulnerability/GHSA-3h8m-483j-7xxm","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-3h8m-483j-7xxm","https://nvd.nist.gov/vuln/detail/CVE-2021-29569","https://github.com/tensorflow/tensorflow/commit/ef0c008ee84bad91ec6725ddc42091e19a30cf0e","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-497.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-695.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-206.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-3h8m-483j-7xxm#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-3h8m-483j-7xxm"}],"summary":"Heap out of bounds read in `RequantizationRange`"}