{"action":"Upgrade codeceptjs to 3.7.5 or later.","affected":[{"fixed":"3.7.5","introduced":"3.5.0"}],"component":"codeceptjs","cve_ids":["CVE-2025-57285"],"ecosystem":"npm","epss":0.02169,"exploited":false,"fixed_versions":["3.7.5"],"ghsa_id":"GHSA-34w8-mcwr-vg29","id":"tcs_01M5KEVY27V0YFX2B6ZRXPE9GS","modified_at":"2025-09-23T20:19:25Z","published_at":"2025-09-08T18:31:42Z","references":["https://osv.dev/vulnerability/GHSA-34w8-mcwr-vg29","https://nvd.nist.gov/vuln/detail/CVE-2025-57285","https://github.com/codeceptjs/CodeceptJS/pull/3604","https://github.com/codeceptjs/CodeceptJS/pull/5190","https://gist.github.com/Dremig/1ba111f9b1f7cffe1fcb4838b64e55b9","https://github.com/codeceptjs/CodeceptJS","https://www.npmjs.com"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-34w8-mcwr-vg29","url":"https://osv.dev/vulnerability/GHSA-34w8-mcwr-vg29"}],"summary":"CodeceptJS's incomprehensive sanitation can lead to Command Injection"}