{"action":"Upgrade recommender-xblock to 1.3.1 or later.","affected":[{"fixed":"1.3.1","introduced":"0"}],"component":"recommender-xblock","cve_ids":["CVE-2018-20858"],"ecosystem":"PyPI","epss":0.00855,"exploited":false,"fixed_versions":["1.3.1"],"ghsa_id":"GHSA-3j5x-7ccf-ppgm","id":"tcs_01M5KEW0D3S2WPMT1QKDMTQS8H","modified_at":"2024-10-26T18:36:32Z","published_at":"2019-08-21T16:15:33Z","references":["https://osv.dev/vulnerability/GHSA-3j5x-7ccf-ppgm","https://nvd.nist.gov/vuln/detail/CVE-2018-20858","https://github.com/edx/RecommenderXBlock/pull/2","https://github.com/advisories/GHSA-3j5x-7ccf-ppgm","https://github.com/openedx/RecommenderXBlock","https://github.com/pypa/advisory-database/tree/main/vulns/recommender-xblock/PYSEC-2019-219.yaml","https://groups.google.com/forum/#!topic/openedx-announce/SF8Sn6MuUTg"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-3j5x-7ccf-ppgm","url":"https://osv.dev/vulnerability/GHSA-3j5x-7ccf-ppgm"}],"summary":"Cross-site scripting in recommender-xblock"}