{"action":"Upgrade packbackbooks/lti-1-3-php-library to 5.0 or later.","affected":[{"fixed":"5.0","introduced":"0"}],"component":"packbackbooks/lti-1-3-php-library","cve_ids":["CVE-2022-31158"],"ecosystem":"Packagist","epss":0.00856,"exploited":false,"fixed_versions":["5.0"],"ghsa_id":"GHSA-5p73-qg2v-383h","id":"tcs_01M5KEW8DEB09AC8Z2QSBF2SXC","modified_at":"2023-11-08T04:09:28.099168Z","published_at":"2022-07-15T20:55:50Z","references":["https://osv.dev/vulnerability/GHSA-5p73-qg2v-383h","https://github.com/packbackbooks/lti-1-3-php-library/security/advisories/GHSA-5p73-qg2v-383h","https://nvd.nist.gov/vuln/detail/CVE-2022-31158","https://github.com/packbackbooks/lti-1-3-php-library","https://openid.net/specs/openid-connect-core-1_0.html#AuthRequest"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-5p73-qg2v-383h","url":"https://osv.dev/vulnerability/GHSA-5p73-qg2v-383h"}],"summary":"LTI 1.3 Tool Library's Nonce Claim Value not validated against nonce value sent in Authentication Request before v5.0"}