{"action":"Upgrade cuyz/valinor to 0.12.0 or later.","affected":[{"fixed":"0.12.0","introduced":"0"}],"component":"cuyz/valinor","cve_ids":["CVE-2022-31140"],"ecosystem":"Packagist","epss":0.01486,"exploited":false,"fixed_versions":["0.12.0"],"ghsa_id":"GHSA-5pgm-3j3g-2rc7","id":"tcs_01M5KEW8MG83T0XEX7XB425AVZ","modified_at":"2023-11-08T04:09:27.300415Z","published_at":"2022-07-12T22:15:29Z","references":["https://osv.dev/vulnerability/GHSA-5pgm-3j3g-2rc7","https://github.com/CuyZ/Valinor/security/advisories/GHSA-5pgm-3j3g-2rc7","https://nvd.nist.gov/vuln/detail/CVE-2022-31140","https://github.com/CuyZ/Valinor","https://github.com/CuyZ/Valinor/releases/tag/0.12.0"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-5pgm-3j3g-2rc7","url":"https://osv.dev/vulnerability/GHSA-5pgm-3j3g-2rc7"}],"summary":"Valinor error messages leading to potential data exfiltration before v0.12.0"}