{"action":"Upgrade wikimedia/parsoid to 0.11.1 or later.","affected":[{"fixed":"0.12.2","introduced":"0.12"},{"fixed":"0.11.1","introduced":"0"}],"component":"wikimedia/parsoid","cve_ids":["CVE-2021-30458"],"ecosystem":"Packagist","epss":0.00977,"exploited":false,"fixed_versions":["0.12.2","0.11.1"],"ghsa_id":"GHSA-5pqx-77vf-85rw","id":"tcs_01M5KEW980V0S672M21TD5W53C","modified_at":"2024-06-07T22:29:02.090533Z","published_at":"2022-05-24T17:47:02Z","references":["https://osv.dev/vulnerability/GHSA-5pqx-77vf-85rw","https://nvd.nist.gov/vuln/detail/CVE-2021-30458","https://github.com/FriendsOfPHP/security-advisories/blob/master/wikimedia/parsoid/CVE-2021-30458.yaml","https://github.com/wikimedia/mediawiki-services-parsoid","https://phabricator.wikimedia.org/T279451","https://security.gentoo.org/glsa/202107-40","https://www.mediawiki.org/wiki/Parsoid"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-5pqx-77vf-85rw","url":"https://osv.dev/vulnerability/GHSA-5pqx-77vf-85rw"}],"summary":"Wikimedia Parsoid vulnerable to Cross-site Scripting (XSS)"}