{"action":"Upgrade tensorflow to 2.4.4 or later.","affected":[{"fixed":"2.5.2","introduced":"2.5.0"},{"fixed":"2.4.4","introduced":"0"},{"fixed":"2.6.1","introduced":"2.6.0"}],"component":"tensorflow","cve_ids":["CVE-2021-41228"],"ecosystem":"PyPI","epss":0.00217,"exploited":false,"fixed_versions":["2.5.2","2.4.4","2.6.1"],"ghsa_id":"GHSA-3rcw-9p9x-582v","id":"tcs_01M5KEWDW01M253QFH38P9DMRJ","modified_at":"2026-07-08T06:28:28.838336090Z","published_at":"2021-11-10T16:54:02Z","references":["https://osv.dev/vulnerability/GHSA-3rcw-9p9x-582v","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-3rcw-9p9x-582v","https://nvd.nist.gov/vuln/detail/CVE-2021-41228","https://github.com/tensorflow/tensorflow/commit/8b202f08d52e8206af2bdb2112a62fafbc546ec7","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-637.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-835.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-420.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-3rcw-9p9x-582v","url":"https://osv.dev/vulnerability/GHSA-3rcw-9p9x-582v"}],"summary":"Code injection in `saved_model_cli`"}