{"action":"Upgrade mlflow to 2.10.0 or later.","affected":[{"fixed":"2.10.0","introduced":"0"}],"component":"mlflow","cve_ids":["CVE-2024-27133"],"ecosystem":"PyPI","epss":0.00656,"exploited":false,"fixed_versions":["2.10.0"],"ghsa_id":"GHSA-3v79-q7ph-j75h","id":"tcs_01M5KEWG1KVT11YM8JNEYM76NZ","modified_at":"2025-04-08T22:30:59.347458Z","published_at":"2024-02-24T00:30:20Z","references":["https://osv.dev/vulnerability/GHSA-3v79-q7ph-j75h","https://nvd.nist.gov/vuln/detail/CVE-2024-27133","https://github.com/mlflow/mlflow/pull/10893","https://github.com/mlflow/mlflow/commit/c43823750bffa5b6abcc086683b15a068513b67b","https://github.com/mlflow/mlflow/commit/cfa71879a884cc3520e23ccab998c9aa78fdf2b1","https://github.com/mlflow/mlflow","https://github.com/pypa/advisory-database/tree/main/vulns/mlflow/PYSEC-2024-241.yaml","https://research.jfrog.com/vulnerabilities/mlflow-untrusted-dataset-xss-jfsa-2024-000631932"],"severity":{"label":"critical","score":9.6},"sources":[{"source":"osv","source_id":"GHSA-3v79-q7ph-j75h","url":"https://osv.dev/vulnerability/GHSA-3v79-q7ph-j75h"}],"summary":"MLFlow Cross-site Scripting vulnerability leads to client-side Remote Code Execution"}