{"action":"Upgrade pgp to 0.14.1 or later.","affected":[{"fixed":"0.14.1","introduced":"0"}],"component":"pgp","cve_ids":["CVE-2024-53856"],"ecosystem":"crates.io","epss":0.00467,"exploited":false,"fixed_versions":["0.14.1"],"ghsa_id":"GHSA-9rmp-2568-59rv","id":"tcs_01M5KEWK56KJTFPXBX9T3J4435","modified_at":"2025-12-26T17:38:33.900409Z","published_at":"2024-12-05T17:30:52Z","references":["https://osv.dev/vulnerability/GHSA-9rmp-2568-59rv","https://github.com/rpgp/rpgp/security/advisories/GHSA-9rmp-2568-59rv","https://nvd.nist.gov/vuln/detail/CVE-2024-53856","https://github.com/rpgp/rpgp","https://rustsec.org/advisories/RUSTSEC-2024-0447.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-9rmp-2568-59rv","url":"https://osv.dev/vulnerability/GHSA-9rmp-2568-59rv"}],"summary":"rPGP Panics on Malformed Untrusted Input"}