{"action":"Upgrade hyper to 0.9.4 or later.","affected":[{"fixed":"0.9.4","introduced":"0"}],"component":"hyper","cve_ids":["CVE-2016-10932"],"ecosystem":"crates.io","epss":0.00738,"exploited":false,"fixed_versions":["0.9.4"],"ghsa_id":"GHSA-9xjr-m6f3-v5wm","id":"tcs_01M5KEWKW4KWWCED0ZC98B794W","modified_at":"2023-11-08T03:58:21.636340Z","published_at":"2021-08-25T20:43:06Z","references":["https://osv.dev/vulnerability/GHSA-9xjr-m6f3-v5wm","https://nvd.nist.gov/vuln/detail/CVE-2016-10932","https://github.com/hyperium/hyper/issues/472","https://github.com/hyperium/hyper/commit/01160abd92956e5f995cc45790df7a2b86c8989f","https://github.com/hyperium/hyper/blob/master/CHANGELOG.md#v094-2016-05-09","https://rustsec.org/advisories/RUSTSEC-2016-0002.html"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"GHSA-9xjr-m6f3-v5wm","url":"https://osv.dev/vulnerability/GHSA-9xjr-m6f3-v5wm"}],"summary":"HTTPS MitM vulnerability due to lack of hostname verification"}