{"action":"Upgrade parse-server to 8.6.77 or later.","affected":[{"fixed":"9.9.1-alpha.1","introduced":"9.0.0"},{"fixed":"8.6.77","introduced":"0"}],"component":"parse-server","cve_ids":["CVE-2026-47138"],"ecosystem":"npm","epss":0.00584,"exploited":false,"fixed_versions":["9.9.1-alpha.1","8.6.77"],"ghsa_id":"GHSA-38m6-82c8-4xfm","id":"tcs_01M5KEWP9PTVMCB92Z90C5W92J","modified_at":"2026-06-16T13:26:25.320958741Z","published_at":"2026-05-23T00:11:25Z","references":["https://osv.dev/vulnerability/GHSA-38m6-82c8-4xfm","https://github.com/parse-community/parse-server/security/advisories/GHSA-38m6-82c8-4xfm","https://nvd.nist.gov/vuln/detail/CVE-2026-47138","https://github.com/parse-community/parse-server/pull/10463","https://github.com/parse-community/parse-server/pull/10464","https://github.com/parse-community/parse-server"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-38m6-82c8-4xfm","url":"https://osv.dev/vulnerability/GHSA-38m6-82c8-4xfm"}],"summary":"Parse Server: Pre-authentication denial of service via client version header regex backtracking"}