{"action":"Upgrade pgp to 0.19.0 or later.","affected":[{"fixed":"0.19.0","introduced":"0.16.0-alpha.0"}],"component":"pgp","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["0.19.0"],"ghsa_id":"GHSA-c7ph-f7jm-xv4w","id":"tcs_01M5KEWRM6PE3SS0K5Q4CWYEQN","modified_at":"2026-02-22T23:23:41.778238Z","published_at":"2026-02-13T20:55:20Z","references":["https://osv.dev/vulnerability/GHSA-c7ph-f7jm-xv4w","https://github.com/rpgp/rpgp/security/advisories/GHSA-c7ph-f7jm-xv4w","https://github.com/rpgp/rpgp"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-c7ph-f7jm-xv4w","url":"https://osv.dev/vulnerability/GHSA-c7ph-f7jm-xv4w"}],"summary":"rPGP's integrity protection of encrypted data was not always checked"}