{"action":"Upgrade ansible to 2.4.6.0 or later.","affected":[{"fixed":"2.4.6.0","introduced":"0"},{"fixed":"2.5.6","introduced":"2.5"},{"fixed":"2.6.1","introduced":"2.6"}],"component":"ansible","cve_ids":["CVE-2018-10874"],"ecosystem":"PyPI","epss":0.00489,"exploited":false,"fixed_versions":["2.4.6.0","2.5.6","2.6.1"],"ghsa_id":"GHSA-3xvg-x47j-x75w","id":"tcs_01M5KEWTS4VAXN2XBEHCM4W5YS","modified_at":"2024-09-09T21:20:36.159737Z","published_at":"2022-05-13T01:07:34Z","references":["https://osv.dev/vulnerability/GHSA-3xvg-x47j-x75w","https://nvd.nist.gov/vuln/detail/CVE-2018-10874","https://github.com/ansible/ansible/pull/42067","https://github.com/ansible/ansible/commit/44874addc7ea136f83c67d5869047ece02645fdb","https://github.com/ansible/ansible/commit/1f80949f964a946773f9d3ac1899535bd2cc2b8e","https://github.com/ansible/ansible/commit/10d6fe6c98cfee9a7be0fea6102ba5dec951aec7","https://web.archive.org/web/20201130165946/http://www.securitytracker.com/id/1041396","https://usn.ubuntu.com/4072-1","https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2018-81.yaml","https://github.com/ansible/ansible","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10874","https://bugzilla.redhat.com/show_bug.cgi?id=1596528","https://access.redhat.com/security/cve/CVE-2018-10874","https://access.redhat.com/errata/RHSA-2019:0054","https://access.redhat.com/errata/RHSA-2018:2585","https://access.redhat.com/errata/RHSA-2018:2321","https://access.redhat.com/errata/RHSA-2018:2166","https://access.redhat.com/errata/RHSA-2018:2152","https://access.redhat.com/errata/RHSA-2018:2151","https://access.redhat.com/errata/RHSA-2018:2150","https://access.redhat.com/errata/RHBA-2018:3788"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-3xvg-x47j-x75w","url":"https://osv.dev/vulnerability/GHSA-3xvg-x47j-x75w"}],"summary":"Ansible Improper Input Validation vulnerability"}